When you install a new theme or add a new module, there might be problems with some of the elements in your eshop. Therefore it's always a good idea to check if the problem is not caused just be "old" templates stored in smarty cache.

Prestashop 1.6 offers very easy way how to clear the cache, so that all templates could be re-generated again.

Go to your back office and find in the menu:

Advanced Parameteres > Performace 

Turn on "Force compilation" and turn off cache.

Now you can get back to the frontend, refresh your theme and see if everything works correctly now. If yes, you may now set the cache on the previous settings. If there's still some problem, there might be really some issue in the theme or the module.

cache


Andrej Staš

Andrej is a Prestashop enthusiast. He started by developing his own themes and then formed the idea of creating Theme Maker. He enjoys finding ways to make his life simpler, and that is the philosophy he incorporates into all his projects. Andrej is also interested in WordPress, Amazon FBA, drop shipping, studying languages, and reading books.

6 Comments

Giuseppe Ferraro · 3 years ago

Good afternoon ,I just installed your theme module but It is not appear the main menu’ and not working good.

What can I do?

thank you,

Giuseppe

    Presta Theme Maker · 3 years ago

    Hi Giuseppe,

    this problem has been already solved in the new versions.

    However, you can simply reinstall the top main menu and it will work again. (Uninstall first and then install again)

Claude GIROLET · 3 years ago

hello andrej

i’m encountering a very big problem, when i’m installing a theme created here the menus are totally messed up, the preview here is great but once on my site, all the menus are rendered with small fonts (i didn’t edit the font in my theme, coz i didn’t want to change the ones used by default. the main menu is total mess the categories are still here but rendered in small texts

please help me i did the personalisation at the very end, when my shop was fully done and filled, i can’t redo it again

Claude

RENATA SOARES · 2 years ago

Hi, I’ve already done the instructions above but I still have some issues. I got a screenshot:
http://rirasplush.esy.es/img/weird.jpg

Using the default theme the same words are being translate just fine.

There are others words in other pages. This is just a exemple.

Can you help me?

BTW. I loved the page maker.

    Presta Theme Maker · 2 years ago

    Hi Renata, please have a look at this page:
    https://prestabuilder.com/troubleshooting-prestashop-16x/

    I explained there how to copy a language from your default theme to your new one.

    “After installation of the new theme the language translations seem to be not complete. Some words are in a different language. What can I do?
    If the translations were correct with the default theme, try to copy them to the new theme manually. On the screenshot you can see English, but in your case choose your desired language.”

    Happy you like Theme Maker :)

Post your comment